Overview Features Download Contact

G280 Series

15793824

G280 Series

The G280/G280P is an entry-level IP phone, and the G280/G280P features a 2.8" high-resolution color TFT display with backlight, which takes visual effects to a new level. The freely programmable multi-color function keys provide users with a high degree of usability. Each function key can be configured for various one-touch phone functions such as speed dial, busy lamp field, etc.
  • 43968710

    2.8”Graphic LCD

  • 94532876

    6 SIP Accounts

  • 60318427

    30 Line Keys

  • 85739261

    5-way Conference

  • 96418253

    PoE

  • 97205186

    HD Voice

87632195

High-definition Audio

62038541
  • Full duplex speaker and microphone
  • Digital signal processor (DSP)
  • Wideband codec: G.722, OPUS-WB
  • Echo cancellation/Dynamic jitter
  • Voice activity detection(VAD)
  • Comfort noise generation(CNG)
43128569

5-way Conferences

G280 Series IP Phone facilitates 5-way audio conferencing, allowing the conference organizer to invite up to 4 participants. This enhances collaboration across various departments or organizations, improving efficiency.
08293146

Support 3rd-party EHS Headsets

G280 Series IP Phone is compatible with third-party EHS wireless headsets (Plantronics, Jabra, and Sennheiser), making it an ideal choice for call center professionals. This feature allows employees to multitask while engaged in audio communication, significantly enhancing overall work efficiency.
68459021

Multiple Programmable Keys

Featuring 30 Line Keys, 4 Soft Keys, all fully programmable, G280 Series IP Phone provides one-touch access to frequently used features like speed dialing, call transfer, and conference calling, boosting productivity by enabling users to customize functions, ensuring efficient and personalized usage.

Easy Management

  • Auto provisioning: FTP/TFTP/HTTP/HTTPS/PnP
  • Intuitive web GUI
  • Dinstar NMS (Network Management System)
  • Configuration via device button
  • Software upgrade via web
  • Network capture

76081435

Product Features

  • 6 SIP Accounts
  • Network capture
  • DTMF:In‐Band,RFC2833,SIP INFO
  • Support 5 Remote Phonebook URLs
  • SIP over TLS,SRTP
  • 5‐way Calling
  • Speed Dial, Hotline
  • Call Waiting
  • Music On‐hold, Intercom, Multicast
  • Narrowband Codec: PCMA, PCMU, G.729, G723, G726
  • Software upgrade via web
  • TR069
  • DNS SRV/ A Query/NATPR Query
  • Phonebook: 500 Groups
  • SIP v1 (RFC2543), v2 (RFC3261)
  • Blind/attendant Transfer
  • Call Forward
  • Call Pickup, Call Pickup in Group
  • SMS, Voicemail, MWI
  • HD Voice

All Parameters

Service Feedback
Service Feedback
Please fill in the information and submit the service
evaluation and suggestions online
  • *Name

  • *Country

  • *Company Name

  • *Email

  • *DeviceType

  • *DeviceSN

  • *Snapshot of Device SystemInformation Page